Error while updating YUM


Today While updating yum on one of the server I  face the error as below ::

=============================================================

[root@323191 yum.repos.d]# yum update
Loaded plugins: fastestmirror
Setting up Remove Process
No Match for argument: epel
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File “/usr/share/yum-cli/yummain.py”, line 285, in user_main
errcode = main(args)
File “/usr/share/yum-cli/yummain.py”, line 136, in main
result, resultmsgs = base.doCommands()
File “/usr/share/yum-cli/cli.py”, line 438, in doCommands
return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
File “/usr/share/yum-cli/yumcommands.py”, line 419, in doCommand
return base.erasePkgs(extcmds)
File “/usr/share/yum-cli/cli.py”, line 861, in erasePkgs
self._checkMaybeYouMeant(arg, always_output=False)
File “/usr/share/yum-cli/cli.py”, line 647, in _checkMaybeYouMeant
matches = self.doPackageLists(patterns=[arg], ignore_case=False)
File “/usr/lib/python2.6/site-packages/yum/__init__.py”, line 2327, in doPackageLists
avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
File “/usr/lib/python2.6/site-packages/yum/__init__.py”, line 897, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File “/usr/lib/python2.6/site-packages/yum/__init__.py”, line 682, in _getSacks
self.repos.populateSack(which=repos)
File “/usr/lib/python2.6/site-packages/yum/repos.py”, line 265, in populateSack
self.doSetup()
File “/usr/lib/python2.6/site-packages/yum/repos.py”, line 92, in doSetup
self.ayum.plugins.run(‘postreposetup’)
File “/usr/lib/python2.6/site-packages/yum/plugins.py”, line 184, in run
func(conduitcls(self, self.base, conf, **kwargs))

=============================================================

Resolution ::

Open File: /etc/yum/pluginconf.d/fastestmirror.conf

vi /etc/yum/pluginconf.d/fastestmirror.conf

Change enabled=1 TO enabled=0

and Fire command

[root@323191 yum.repos.d]# yum clean all
[root@323191 yum.repos.d]# yum update
It should be fixed🙂🙂🙂

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: